Introduction

概述

<电脑万能遥控器> 可以让你通过遥控器控制电脑上几乎所有的软件，抛开了键盘和鼠标的束缚，通过红外遥控器遥控电脑，你就象在家里遥控电视机、DVD等家电一样方便，电脑上的MP3，DVD电影等的普及应用，通过本遥控器能更有有效更好的管理你的多媒体系统，本遥控器可以模拟键盘击键、鼠标按键及移动、启动电脑上的任何软件、向某个软件发送消息、音频系统控制、开关机操等，通过这些指令的组合，可以实现很复杂的应用，比如用一个键启动WINDOWS的媒体播放器，一个键对应“播放键”的快捷键，一个键控制系统音量+，一个键控制系统音量-，就可实现对媒体播放器的控制。

<电脑万能遥控器> 可任意选配一款家用DVD遥控器作为电脑的遥控器，每家每户都有，不需另外购买，只需<电脑万能遥控器> 控制软件和以下任一款我们出品的接收器就可以实现电脑遥控。

1、型号：YG-168，USB接收器 （支持东芝和NEC格式的遥控器，95%VCD，DVD遥控器为该NEC格式），推荐！

2、型号：YG-920 V6.0，红外遥控编码分析仪上所使用的接收设备，可以支持更多遥控器。

3、型号：YG-201/YG-301/YG-302/YG-303/YG-305，遥控器检测仪，可以支持更多遥控器。

组成

控 制 软 件：电脑万能遥控器 专业版 V3.0

标配接收器：YG-168 USB接收器

联系信息

开发天地出品

联系人：覃远高

Tel: 13316529329 电话/传真：0755-82895478

主页：http://www.mcusky.com 信箱：qinyg@tom.com

地址：深圳市福田区莲花北路长城盛世二期8栋32D 邮编：518033

下一个:

基本概念


Commands

遥控器及按键

在这里可以管理多个遥控器以及它们对应的按键，学习（记录）好按键所对应的遥控指令码，以便指派这些按去触发受控软件的动作。

- 想知道怎样建立、重命名、删除、移动遥控器及按键，请看 管理遥控器及按键.

- 想知道怎样学习（记录）按键指令码，请看 学习按键.

- 想知道按键的其它属性，请看 按键属性.

下一个:

动作


Learning commands

学习按键

要使用一个遥控器按键，必须要能够识别它，在软件中可以通过简单的方法学习好每个键，使它们有对应的关系，在正常使用时，按遥控器的按键，控制软件就能够识别该按键并执行对应的动作。
每当新建一个按键时，自动弹出学窗口，也可以选择菜单“遥控器/学习按键编码”，然后按遥控器上对应的按键，收到的编码会显示出来，点击“OK”确定即可。

查看窗口例子
隐藏窗口例子

在遥控器上按对应的按键发出信号,将被学习下来。

下一个:

按键的其它属性


Actions

动作

动作就是响应遥控按键的行为，可以包含多个指令，比如你想启动一个音乐播放软件同时播放一首歌，名为“Play”的按将触发一个动作，这个动作下有两条指令，一条指令启动音乐播放软件，另一条播放音乐。

管理动作

你可以在控制软件的主窗口中的“目标软件和动作”列表中建立、删除、重命名一个动作，每当在目标软件下建立动作，就可以在“触发按键”表中加入触发执行该动作的按键，可以在“动作指令”表中加入控制指令。

  • 想知道如何为一个动作指派触发按键，请看 触发动作的按键

按“新建(N)…”开始在动作指令表中加入新指令，并对该指令进行设置。

当一个动作下有多个指令时，设置“每次执行几个指令”的值为0，每次将同时执行这些指令，否则每次将轮流执指定数量的指令。

在电脑上可以模拟的指令
  • 击键 : 模拟键盘击键，可以指定Alt, Ctrl 或Shift键。
  • 鼠标 : 模拟鼠标移动和鼠标按键。
  • 执行应用程序 : 执行应用程序和打开文档。
  • 发送消息 : 向其它应用程序发送windows类型的消息。
  • 音量控制 : 控制系统音量.
  • 系统 :
    • 注销、重启电脑、关机。
    • 窗口状态设置。
    • 屏显（OSD），显示系统信息或任意文字。
其它动作设置选项
  • 执行下一个指令前的延时

单位为毫秒（0.001秒），当有几个指令需要同时执行时，执行下条指令前需要等待的时间。

  • 目标软件窗口

有些指令是需要发到指定目标窗口的，比如发送消息，控制软件每次执行指令前，首先查找目标窗口是否存在，如果找到指令将被发到目标窗口上，否则无效。控制软件通过标题名和类名来查找目标窗口，有些应用软件的窗口标题会变化，此时最好把标题内容设为空，否则将找不到目标窗口。

  • 允许连续按键

连续按键是指当遥控器按键长时间压住不放的情况，此时遥控器每0.108秒发一次信号，如果该选项被选中，将在每0.108秒触发执行一次本指令，如控制音量时连续增加或减小音量，就应该选中本选项。

  • 按键延时时间

指首次按下键到重复键的延时。

  • 连续按键时间

每次连续键的延时。

下一个:

触发动作的按键


Key press action

模拟键盘击键

本指令让你可以用遥控器产生键盘一样的按键，可以模拟出系统标准的按键和其它能在键盘打出来的按键，

能模拟出的按键有：

  • Enter, Space, Delete, Home, End, Insert, PageUp, PageDown, Tab, Esc, BackSpace
  • 方向键: Left, Right, Up, Down
  • 功能键： F1-F12
  • 小键盘：0-9，*，+，-，/
  • Pause, CapsLock, NumLock, ScrollLock, PrintScreen
  • Windows 键: 左Win, 右Win, Application
  • Alt,Ctrl,Shift,Windows

所有按键可加入 Alt, Ctrl, Shift 和 Windows键。

下一个:

模拟鼠标移动和鼠标按键


Mouse move action

模拟鼠标移动和鼠标按键

模拟鼠标按键

可以选择左、中、右键击键，或者按键按下/放开用在更高级的应用（如拖动等），选择“双击”选项，可以模拟鼠标按键双击动作。

相对鼠标移动

让鼠标光标在原来位置的基础上按指定的方向移动一定距离，加速度指定每次移动的点数。

鼠标光标移动到绝对位置(x,y)

让鼠标光标移动到屏幕指定位置，精确到像素，坐标由X，Y决定，屏幕左上角为原点0，0。按F2键复制当前光标位置填入X，Y坐标。

下一个:

执行程序


Postmessage action

发送消息

有些应用程序需要通过发送windows消息的方式进行控制，我们可以向该应用程序发送windows消息或自定义的消息进行控制。

可以为这些消息设置参数wParam 和 lParam， 十六进制。

自定义的消息在userdefine.txt文件中，你可以自行更改。

下一个:

音量控制


Volume control action

音量控制

本指令允许你改变声卡的音量或者改变静音状态。

混音器

显示安装在你电脑上的所有声卡，请选择一块你想控制的声卡。

音量类型

在这里选择播放音量、录音音量等.

混音器线路

在这里选择需要控制的混音器线路，通常第一个混音器线路是系统的总音量。

音量

在这里选择音量增/减，可以设定每次增/减的量。

静音开/关

控制静音的开或关。

下一个:

系统指令


Miscellaneous actions

系统指令

这里包含一些相关系统的指令，分为3大类。
关闭电脑

分为:

  1. 注销
  2. 重启
  3. 关机
  4. 挂起
  5. 休眠
窗口状态

改变当前活动窗口的状态，有最小化、最大化、还原、关闭。

屏显（OSD）

在屏幕上临时（几秒钟）显示一些文字信息。

下一个:

触发按键表


Triggering

触发按键表

在遥控器按键和动作之间建立触发执行关系，给动作指定触发的按键。

如何给动作指定触发按键
1. 在控制软件主界面中的“目标软件及动作表”栏中选择要设置的动作。

2. 在“遥控器及按键表中”选择要触发该动作的按键。

3. 用鼠标拖动选中的按键到“触发按键表”中，或点击右键，选择“加入触发按键表”。如下图：

查看窗口例子
隐藏窗口例子

删除触发按键

在要删除的按键上按鼠标右键，选择“删除”，或者按键盘“Delete”键，删除只是从该动作的按键触发表中删除触发关系，并不会从遥控器及按键表中删除按键。

触发按键属性
  • 触发有效/无效，让你可以选择按键是否可以触发该动作。
  • 按键组合模式，“全部键”是指当所有触发按键表中的按键都被按过才执行动作，“任何键”是指只要触发按键表中的一个按键有效就执行动作。

下一个:

受控软件及动作


Layouts

受控软件及动作

在这里定义接受控制的软件以及它们的动作，如果受控软件的窗口有效时，才能由遥控器按键触发它所包含的动作。

例如：你建立了一个 “播放” 键，但在“媒体播放器”上的播放动作和在“DVD播放器”上的播放动作是不一样的，那么我们可以在这里同时定义这两个受控软件，并为它们的“播放”动作指派同一个遥控器“播放”按键，当“媒体播放器”运行时，如果你按了遥控器“播放”键，控制软件将执行“媒体播放器”下的“播放”动作，比如模拟快捷键'x'，但如果“DVD播放器”正在运行，就执行“DVD播放器”下的“播放”动作， 比如模拟快捷键'Ctrl+p'，换句话说，根据当前运行不同软件，你可以用同一个键触发不同的动作(模拟快捷键 'x' 或者 'Ctrl+p') 。

更多信息请看 设置受控软件

下一个:

其它设置


Layouts

设置受控软件

选择菜单“受控软件/增加新受控软件”可以建立一个新的受控软件，或者对某一个受控软件按右键选择“属性”对它重新进行设置。

查看窗口例子
隐藏窗口例子

  • 名称

为你的受控软件取一个名字，可以任意写，但最好看得明白。

  • 当前窗口为以下窗口时动作指令才有效

控制软件在电脑上正在运行的软件中查找当前（最前面激活）窗口，如果和设置的一样，就执行该受控软件下的动作，你可以选择“任意窗口”，就会一直执行它的动作。

  • 动作指令发到以下窗口（也叫目的窗口）

模拟控键 和 发送消息 这两种指令类型需要指定目的窗口， 如果选择“指定窗口”，所有该受控软件下的动作将被统一发到指定的窗口，你也可以选择“由指令设置决定”，将在每条指令里设置可以发到不同窗口。

  • 标题

软件窗口的标题，就是平时我们看到的窗口顶端所显示的内容，控制软件通过窗口标题来识别软件窗口，可以通过按“设置”键，从正在运行的软件中选择。

  • 类名

类名更加能准确识软件窗口，如果你不知道可以不写，那么只由标题来识别窗口。

下一个:

其它设置


Program settings

其它设置

开机自动运行

这个选项决定<电脑万能遥控器>控制软件是否在电脑启动后自运行。

自动最小化到托盘图标

当这项被中时，<电脑万能遥控器>控制软件启动后将最小化到托盘图标，打开接收端口并开始接受遥控指令；否则的话显示主界面，不打开端口，也不接受遥控指令。

当收到红外遥控按键时播放声音

当遥控指令被正确识别时，播放“BEEP”声。

允许同时运行多个程序

在某些情况下，你可能希望运行多个<电脑万能遥控器>控制软件，那么选中该选项，否则只能运行一个。